mozdev.org

FlashBlock

resources:
info:

install for: Firefox 1.0.x
Mozilla suite 1.7.x
SeaMonkey
Netscape 7 to 9.0
Other browsers:
Camino
K-Meleon
Galeon
OS Specific:
FreeBSD Ports
RPMs
 

For Mozilla Suite 1.7, Netscape 7, and Netscape 8, please use Flashblock 1.3.15 (scroll down for the installation link).

IMPORTANT! Please see the Known Problems page before installing
If you are reinstalling or upgrading to a newer version of Flashblock you MUST remove the existing installation of flashblock first (not needed for Firefox 1.5 and newer, and Flock).

Netscape 8 users will need to download and install multibarfix-0.1.1 if you want to use the Flashblock toolbar button.


Removal The Uninstallation Guide for Mozilla Suite and Netscape 7 can be found here: http://flashblock.mozdev.org/uninstall.html

Installation Click on one of the links below to install Flashblock. Note that you must restart your browser for flashblock to be enabled.

Install Flashblock 1.3.unstable for Firefox 4.0+ and SeaMonkey 2.0 to 2.19a. WARNING: This is the developmental version containing the latest features but is untested and may contain unknown bugs. USE AT YOUR OWN RISK!

What's New:
  • Nothing yet.

Install Flashblock 1.3.20 for Firefox 4.0+ and SeaMonkey 2.0 to 2.18a.

What's New:
  • [fix] Bug 24896 Allow whitelist for some sites. Patch by Tommy Wu.
  • [fix]Re-enable whitelist integration with Adblock Plus and other content blockers.
  • [fix] Don't enable controls for HTML5 video/audio since some sites (Youtube) have their own video controls.
  • [new] Add option to enable/disable HTML5 video blocking.
  • [fix] Bug 25350 Flashblock on Firefox 21 is broken by mozilla Bug 834697 (Enable XBL Scopes).
  • Updated translations from Babelzilla.

Install Flashblock 1.3.19 for Firefox 3.0+ and SeaMonkey 2.0 to 2.16a.

What's New:
  • [new] Preliminary support for blocking HTML5 Video.
  • [fix] Disabled whitelist integration with Adblock Plus and other content blockers since this prevents our whitelist from working on Firefox 13.

Install Flashblock 1.3.18 for Firefox 3.0+ and SeaMonkey 1.0 to 2.9.

What's New:
  • Updated locales from Babelzilla including: fi-FI, uk-UA, it-IT, de, fr, he-IL, da, ko-KR, ru-RU, zh-TW, ja-JP.
  • New locales: hy-AM, th, eo, hsb-DE.
  • [fix] no-NB locale should be nb-NO ( Norwegian bokmal).
  • [new] Add an option to Sync the whitelist using Weave/Firefox Sync.
  • New OS X placeholder images from: Bug 614485.
  • [fix] Bug 23456 Flashblock blocks all flash-based gadgets.
  • [fix] NS_ERROR_DOM_NOT_FOUND_ERR in flashblockShowFlash().

Known Issues:
  • Some flash in IFRAMEs is not blocked. This appears to be a Mozilla bug. See: Bug 652300.

Install Flashblock 1.3.17 for Firefox 2.0+, SeaMonkey 1.0 to 2.1b, and Netscape 9.0.x.

What's New:
  • [fix] Bug 18971 Please integrate nicely with content blockers (Adblock Plus).
    • Fix Firefox 2.0 regression caused by patch in Bug 18971.
    • Fix sIFR breakage caused by patch in Bug 18971.
  • [fix] Bug 22683 "document.createEvent is undefined" error prevents Flashblock from working.
  • [fix] typo in install.js (Flashblock 1.3.17a only).
  • [fix] Camino Bug 573815 Flashblock does not display play button on Dailymotion videos.
  • Add <em:unpack>true</em:unpack> to the install.rdf to force Firefox4/SeaMonkey 2.1 to unpack the XPI.

Known Issues:
  • Options checkbox to control silverlight blocking is off by default due to Bug 22469 (Silverlight movie not unblocked).

Install Flashblock 1.3.16 for Firefox 1.5+, SeaMonkey 1.0 to 2.1a, and Netscape 9.0.x.

What's New:
  • [new] Options checkbox to control silverlight blocking (off by default).
  • [new] Dynamically change the toolbar button label depending on block state.
  • [new] es-AR and sr-RS locales from Babelzilla. (translations now provided by Babelzilla)
  • [fix] Bug 22168 "Node was not found" code: "8".
  • [fix] For the sIFR-alternate binding move the position: static style from the css into the XBL. This used to crash Firefox 1.0.7.
  • [new] Desupport Gecko 1.7 browsers (Flashblock 1.3 branch).

Known Issues:
  • Options checkbox to control silverlight blocking is off by default due to Bug 22469 (Silverlight movie not unblocked).

Install Flashblock 1.3.15 for Firefox 1.0.x, Mozilla Suite 1.7.x, SeaMonkey 1.0 to 2.1a, and Netscape 7.2 to 9.0.x.

What's New:
  • [fix] Bug 20817 Make Flowplayer work with Flashblock instead of offering to download the .flv file. Includes a followup fix to include other formats offered for download including .MP4
  • Ongoing refactoring of Flashblock code.
  • Detect more broken flash and stealth flash objects.
  • Add ".*" to the end of the whitelist strings during compare so users don't have to do this manually.
  • Initial support for blocking Silverlight. Thanks to Sven Schneider for the silverlight buttons

Install multibarfix-0.1.2 for Netscape 8.0/8.1.3 (Required for Flashblock).

To test your flashblock installation, visit this page: http://www.adobe.com/shockwave/welcome/


IMPORTANT:

Older Versions Older versions of Flashblock can be found at: http://downloads.mozdev.org/flashblock/

For questions or comments about flashblock, please send a message to the flashblock mailing list.
Copyright © 2000-2014. All rights reserved. Terms of Use & Privacy Policy.